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SARMAP V7.2.0 RELEASE NOTES 2021

1 INTRODUCTION

Since 1979, RPS has been researching drifting objects, oils, and chemicals at sea. As part of that we
developed a search and rescue operational tool called SARMAP and this tool is now used in many countries
including Spain, Netherlands, Australia, Korea, New Zealand, Ireland, Argentina, Brazil, Ireland, Isle of Man,
U.S.A and others. SARMAP is a commercial tool and is available as a stand-alone tool.

Version 7.2.0 of SARMAP includes many enhancements and added features to help improve search and
rescue response. Enhancements were made to both the model and the user interface. This document
describes the various new features and bug fixes included in SARMAP v7.2.0.

1.1 Operating System Compatibility

Version 7 (and newer) of the RPS MAP applications, OILMAP, SARMAP, and CHEMMAP, are supported on
the following Microsoft Windows platforms: Windows 10, 8, 7, Windows Server 2012 and 2016. Microsoft
Azure, and Amazon Web Services.

"‘ ml Windows =
> weaoe | W0 Server 2012

Windows'7 i Compatible
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2 SARMAP V7.2.0 USER INTERFACE UPDATES

2.1 Resolved Interface Bugs/Issues

The following bugs have been reported, logged, and fixed:

1. The SRU search speed in the Endurance tab now updates based off the search speed from the
Search tab. This is true for both airplane/helicopter search units for marine searches and light/heavy
aircraft for land searches.

L BICGS =] 5L BICGS =]
Search Endurance  Search Pattern = SearchArea Search Endurance | Search Pattern = Search Area
(&) Marine Search () Land Search Point of Departure: ¢} Point of Return: {J»
Search Unit: |Airplane j Lon | 741.580347 W m Lon | 71.580347 Wl
Lat 41.192608 N Lat | 41.192606 N
Search Object: |Persun in Water j SRU Transit Speed (knots): 30.00
Met. Vigibility (NM): |'1E- j 5RU Search Speed (knots): 150.00
Weather: |Calm j SRU Total Endurance (hours): 24.00
Altitude (ft): |300 - Distance to Search Area (NM): 28.07
search Speed (knots): - Distance from Search Area (NM): 3274
Effective On-Scene Endurance (85%):
Include Fatigue Factor
18.00/hrs|  41.00 mins [] Lock
Suggested Sweep Width: 0.108 MK
= |
Next == =< Previous Next ==
0D-PO 0
Cne Search POD:  10.37 ‘ One Search POD: 10.37 I
POC: 0.00 POC: 0.00
POS: 0.00 | POS: 0.00 |
Create Report Undeploy SRU Apply Close F Create Report Undeploy SRU Apply Close |

Figure 1. Endurance tab Search Speed updates based off Search tab

2. When deploying a ‘Boat’ as an SRU, Search speed is now saved in the Seach tab of the deployment
form.

Removed false error messages when saving search patterns from SRU.
SRU deployment form now saves when you switch search unit and close the form.

Resolved issus with creation of User-Defined SAR Area (rectangle, polygon, and manual entry),

o 0 > w

Now allowing for the adjustment of the time slider when the SRU deployment form is open to dictate
when the SRU will be deployed.

When undeplying SRU, the search area now deletes from map.

Fixed distance calculation when changing the departure and arrival locations of an SRU.
9. Fixed errors with Live SRU forms.
10. Effective On-Scene Endurance in SRU form is now text field users can edit.
11. Stopped software crash when attempting to subdivide a user-defined search area.

12. Fixed to allow spaces in ‘Description’ in the Model Input form (now creates XML report for cases with
spaces in the Description).

13. Incomplete sentence in Parameters tab (Model Input form) now complete.

14. Two tracklines are now drawn when running a scenario with two accident sites.
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15.
16.
17.
18.
19.
20.
21.
22.
23.

24,
25.
26.

27.

28.
29.

Stopped software crash when editing the speed of a trackline scenario and re-running.

Fixed issue with trackline time labels.

Correctection to justification of Point layer name.

Correction to postion of Polygon layer name.

Start and end time of time slider tool form now matches the start and end time of your scenario.
Fixed issue with Timeslider controls preventinig display of data.

ABDC box no longer increases when particles are stuck on land.

Fixed mismatch between search patterns and ABCD box.

During IAMSAR scenario, the center point and trackline are now calculated as center point of ABCD
box.

Moved ABCD box to lower left window of the map instead of upper right.
Updated to MSXML v6.0.

The components constrained Downwind and Crosswind Leeway have been updated for PIW with
type | PFD and in a Survival Suit, besides from the average PIW with PFD an PIW without PFD.

Average leeway date and divergence angles for PIWs (2018) has been updated for the IAMSAR
calculations.

The PIW Type |, Il and lll titles have been modified as they were mistaken on SARMAP.

New SAR objects have been included with their values corrected: Canoe, Kayak and Stand Up
Paddleboard.

rpsgroup.com Page 3
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2.2 New Feature Additions to the Interface

2.2.1 Scenario Batch Mode with EDS

It is now possible to run multiple duplicate scenarios in SARMAP using a
variety of available datasets from the Environmental Data Server (EDS).
Users can simply create a scenario with the desired inputs and use it as
the parent case. This scenario is created in the usual manner by going to
File -> New Scenario.

Once the base case is created the user goes to Model -> Run Batch
Mode with EDS.

The Batch Input Mode with EDS input form opens.

Lacenano [LhUsers\Fubhc\Uocuments\ ALA Sottwi
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Model Tools COASTMAP Help
Select Accident Site
Add Accident Site
Add TrackLine (waypoints of missing vess:

Run SAR Model

Add Fixed SRU
Add User-Defined Search Area

Model Display Settings

Run Batch Mode
Run Batch Mode with EDS

Export to Shapefile/Google Earth File

The user can now create multiple scenarios using the same inputs from the parent scenario and select a
variety of wind and current data sources from EDS to compare the trajectories created. The user simple

clicks the plus button ﬂ to add an additional scenario or the delet button

to remove a scenario.

iy Batch Input Mode With EDS X
scenario Name
Scenario Name Winds Currents
Parent Scenario Name_1 GFS (NCEP) j Copernicus, GLOBAL j + | K ;I
Parent Scenario Name_2 GFS (MCEP) =] Global HY'COM (Navy) Curr; + | X
Parent Scenario Name_3 Iet Office Global Atmesphi * | | Copernicus, GLOBAL =] + | X
Parent Scenario Name_4 rdetOfﬁceGmhalAtmusphuj Global HYCOM (Mavy} t:urrj | X
-
Go Close

From the dropdowns for winds and current the user can select from the available options and once all

. . Go . . .
scenarios have been setup the user clicks to sequentially run the desired scenarios. All outputs
will be added to the scenario data store and can be accessed using File -> Open Scenario. Multiple

scenarios may also be displayed using File -> Add Scenario.

rpsgroup.com
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2.2.2 Map Coordinate Markings Display Update

SARMAP now allows you to view the map with latitude and longitude displayed as tick marks rather than
gridded. To enable this feature right click on the map and choose ‘Map Display Settings’. A settings box will
appear and under Viewing Options check ‘Display Tick Marks Only.’

Map Display Settings
Maodel Display Settings

Base Map
Add Layer

A — =
% Map Display Settings

1g Options

Degree Representation |DD.DD -

1 Land Color
- - - - - -

// ¥ o Water Color E] Current Vector Units mis -
-s-&s-&"“"/mx ) )
\_\//Y'/ Land Outine Col E] |:| Distance Units NI 7
and Outline Color
b e S S i e g s N T E GTE
is ki
Lon/Lat Grid Color
R e S (=)
- 9 Current Wector Color
-~ = mp sy > s> s> = ] Di ick M H
. Rphy, Ty, | Display Tick Marks Onby \ind Vector Color @
- ‘»»»“ . .t Display Distance Scale Window .
i User Defined Vector Color @
- -y
- A S S0 R b SaveZuumWinduwstu Disk OLineArruw
- mp wp e s wmp mp wmp mp Project (O Thick Arrow (Shadow) ‘ n
rojection |Wercator =l () Thick Arrow (No Shadow}
o R SR L A L L G AL () Fixed Size Arrow
- mp e A A = = o =y mp wmp |:|FixedHead(Stemunlyshuwsstrength} |
oK Cancel
e __J — —= — .

Figure 2. Longitude and Latitude displayed as tick marks

2.2.3 Aeronautical Model 3D EDS Winds

A new feature to SARMAP is 3D EDS winds. In the Run SAR Model box (Ctrl + R), navigate to the Object
tab. Under Site Details, click the button next to Wind Speed vs Elevation and a new box will appear. In this
new box, there are three columns: elevation, wind direction, and wind speed. Below these columns there is a
Get Data button at the bottom of the box that pulls EDS data for the specified site from the GFS (NCEP)
winds source. An upgraded EDS subscription is required for this feature. Please contact us at
MapSupport@rpsgroup.com to enable this feature.
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B2 Wind Speed vs Elevation

Use of these manual vertical winds disables the use of time
series winds or EDS.

Elevaton () WindDrecon  Wind Speed (its)
[ 44542| | 260/ | 101
#F Search and Rescue Model X 20| |
| & . 33,418 | 250/ | 13|
A 3 % <X 2 29.444) | 251 | 134
Scenario L Object Winds Parameters Review 26,057 ‘ 2‘9‘ ‘ 'ﬁl
y 23,085 243 | 107
Aeronautical Objects
20,328 | 244) | E2l
5 0 aireraft & 17,825 \ 215\ \ n|
i) Generic Airplar
R Bne::?ﬁ'ﬂ " 15522 | 243 | &3]
O Boeng 747 13,387| | 242 | 57
-0 Bosng 737-200 11,404) ‘ 2"‘ ‘ 35|
DO Cessna 4-seat
O Jet Transport 5,550] | 247 )
O satPane v 7,308 28] | 25
6157 | L]
Object Hame Boeng 767 || asitude 1) 38,000 4,505] 284 24
[ | Gide Ratio 1200 Giige True AirSpeed | 21000 Vind Speed vs Elevaton | B2 3108 | 302 | 2
Descent Rate (f/Min) 0.00] DescentHeadng | 320,00, 2,363 | 302 | 25|
1,695 \ m\ \ 22|
[] Aavenced Optons 1014] | 297 | 18
Il Save as Default 4 Previous P Run SAR Model + Net D ciose ]| 7] | El
Enter the wind 5 hest sievston
‘ GetData ,
 ——
ClearAll oK Cancel

N

Figure 3. Wind Speed vs. Elevation data pulled from EDS
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224

Introduction of Cases

There is now a new addition of case name when creating a new scenario. You have the option to assign a
case name when creating a new scenario in the SARMAP Scenario Setup box. When opening an existing
scenario, there is the option to filter by case name in the Open SARMAP Scenario box. The option to delete
a case name is also available. To do so, go to Delete Scenario Files in the drop menu under the Tools tab of
the interface. Choose SARMAP Cases in File Type, then choose a case to delete from the list.

= Open SARMAP Scenario

&8 SARMAP Scenario Setup

47 | 567045

82 2010428

W

() DDOD
(3) DD MM.MM
() DD MM 55

Ilandpury.tn:lm

OK

Cancel

Case Name [ Filename Size (KB) | Modified Date [ Model Type
Casel C1_SCENARION SRP 4 12-Feb-20 1102 IAMSAR
Casel C1_SCENARIOZ SRP 4 12-Feb-20 12:13 IAMSAR
Casel C1_SCENARID3 SRP 4 12-Feb-20 12:15 IAMSAR
Case2 C2_SCENARIO1 SRP 4 12-Feb-20 11:1¢ IAMSAR
Cased C3_SCENARID1 SRP 4 12-Feb-20 12:00 IAMSAR
™ |Cases C3_SCENARIOZ SRP 4 12-Feb-20 12:04 IAMSAR
Cased C4_SCENARID1 SRP 4 12.-Feb-20 11:58 IAMSAR
Cases CS_SCENARIOT SRP 3 12-Feb-20 12:12 IAMSAR
| | |cases C5_SCENARIO2 SRP 3 12-Feb-20 12:16 IAMSAR
Cases CS_SCENARIOZ SRP 3 12-Feb-20 12:24 Monte Carlo
Case6 C6_SCENARID1 SRP 2 12-Feb-20 12:22 Monte Carlo
o
OK Cancel

rpsgroup

.com

Figure 4. Add Case Name
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ia; Delete Scenario Files

(7) Sarmap Scenarios

(%) Sarmap Cases
() Wind Files

(") Grid Files

() Current Files

[ {none)
[ |Caset
[1Case?
[[Cased
[Ca=ze3

[ Casef

Delete Close #
|
| T b v N
[ Open SARMAP Scenario
Case Name Filename Size (KB} | Modified Date I Model Type
C5 _SCENARIOT.SRP 3 12-Feb-20 12:33 L&MSAR
C5 SCENARIOZ SRP 3 12-Feb-20 12:33 L&MSAR
C5_SCENARIO3.SRP 3 12-Feb-20 12:33 Monte Carlo
Casel C1_SCENARIO1.SRP 4 12-Feb-20 11:02 LaMSAR
Casel C1_SCENARIOZ SRP 4 12-Feb-20 12:13 L&MSAR
Casel C1_SCENARIO3.SRP 4 12-Feb-20 12:15 L&MSAR
Case2 C2_SCENARIO1.SRP 4 12-Feb-20 11:14 LaMSAR
Case3 C3_SCENARIO1.SRP 4 12-Feb-20 12:00 LaMSAR
|| | Cased C3_SCENARIOZ SRP 4 12-Feb-20 12:04 L&MSAR
Cazed C4_SCENARIOT.SRP 4 12-Feb-20 11:58 L&MSAR
Cased C8_SCENARIO1.SRP 2 12-Feb-2012:22 Monte Carlo
Case |Show AllCases j Ok Cancel

rpsgroup.com

Figure 5. Delete Case Name
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2.2.5 Help Menu updates

By clicking on Help tab in the top file menu toolbar, you can now reach the License Administration and the

Maintenance Site by clicking on either in the dropdown menu.

\STMAP | Help

= Contents E
bn Move About SARMAP Srid Cell

D

22V Terms Of Use
License Administration

Maintenance 5Site

Sentinel Admin Control Center

Admin Control Center Help

« Defining valuss for Products with dstachabis licanses

The Diagnostics page enables you ta view system information related 1o the current Sentinel License Manager. and to generate regorts

Copyvight © 2018 SafeNet. All ights reserved

P Admin Control Center Help
Prosucts
Foanres
Sessions Wielcame to the Admin Contral Center This application enables you to manage access to software licenses and Features, 1o control detachable licenses. ta control sessions. and 1o diagnose problems.
Mote: You can selectthe anguage n which Adin Canivol Cender is displayd by clicking he courtry 1ag 4ppropiate 1o the roguired Janguage (Gsplayed al e botiom of e Options pare). To view all avalabe langusges, of 10 downlaad ofher Wnguage packs, click the More
Updata/Altach Languages ik
Tha Admin Control Center enables you ta monitor the following
Access Log
Configuraion « Alths Saninel protection keys that ars currently available on the natwork server, including thair idensiy, typs, and location
+ The number of users currensly logged in to a protection key, and the maximum number of users allowsd 1o be simultaneously logged info that speciic key
Ciagnastics. + The Features 10 which each peotection key allows access, and any restrictions that apply 10 the Feature
+ The users who ars curentl logged nto 8 specific protisction key, including detabed logn information
el
=t Wots: L Ussrhod keys are only diaplayed for the local machine. SL UsseMada keys ara not displaysd whan the canfiquraton paramater Do Not Load hasplmv.axs & selscted
You can perform actons, such as
+ Detaching a lcense from the netwark and attaching 1 1o your maching or  diferent recilent machine
+ Cancallng a detachabls kcense prematuce
+ Instaling an updata 10 a icarse on 4 key Tat is viskle in Admin Control Contar
You can make basle conguration changes, inchuing
+ Satting the display refresh time
+ Configuring access pemissions fom a cient machine 1o remote server and canfiuing a server 1o allow 10 be remately accessed

Revision 1510-2

Figure 6. License Administration
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