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Overview 
This Open Plan 8.2 Cumulative Update 11 release includes all of the enhancements and software issues 
resolved in Open Plan 8.2 CU 01 through CU 11.  

Custom Programs Affected 
Sometimes an update can cause custom programs and reports to stop working as expected. Before 
applying this update, consider whether you have any custom programs or reports in the application area 
affected by the update. If so, contact Deltek Customer Care at http://support.deltek.com before you install 
the update. 

 
 

Attention: For steps to install the cumulative update, see Appendix A: Download and Install the 
Cumulative Update. 

http://support.deltek.com/
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Open Plan 8.2 Cumulative Update 11 
Released: August 30, 2019 

Enhancements 

Support for Oracle 18.3 
Open Plan 8.2 now supports Oracle 18.3. 

Software Issues Resolved 
Project » Cost Calculations 

Defect 1133566 
Description: Budget Cost did not match Budget Qty when using a baseline created on Late Dates 
and running cost calculations with unit cost=1. 
Customers Impacted: All Open Plan customers using Open Plan 8.2 CU3 with baselines based on 
late dates. 

Workaround Before Fix: None. 

Files Updated: OpenPlan.Process.dll 

 

File » Change Mode 
Defect 1144900 
Description: In shared mode, when a user had a temporary lock and released locks (unlocked the 
project) after making changes and choosing not to save the changes, unsaved changes remained in 
the user's local copy of the project. 

Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None. 

Files Updated: openplan.engine.dll 

 OpenPlan.Language.409.dll 

 
Defect 1150446 
Description: The fix for defect 1075899 (Slow performance applying a shared mode lock on large 
multi-projects) in Open Plan 8.2 CU07 had side effects for the integration between PM Compass and 
Open Plan. This update resolves those issues while retaining the performance improvements. 
Customers Impacted: All customers using Open Plan and PM Compass 

Workaround Before Fix: Stay on Open Plan 8.2 CU6. 

Files Updated: openplan.engine.dll 
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Edit » Activity Details 
Defect 1149751 
Description: In shared mode, when a user added an activity, and a second user tried to add the 
same activity using the Activity Details dialog, Open Plan would indicate the activity already existed 
but then blank the contents of the activity. 
Customers Impacted: All Open Plan customers working in Shared Mode, 

Workaround Before Fix: If the second user uses the spreadsheet or barchart instead of the Activity 
Details dialog box to add the same activity that the first user has already added, the row will be 
correctly updated. 

Files Updated: openPlan.exe 

 
Defect 1165140 
Description: Open Plan exhibited inconsistent behavior when multiple users edited an activity on the 
Activity Details dialog box in shared mode. 
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Edit the activity in the spreadsheet instead of the Activity Details dialog 
box, then re-launch the Activity Details dialog box to refresh the activity. 

Files Updated:  openplan.exe 

 

Edit » Activity Progress 
Defect 1168798 

Description: An SQL.log was created but not populated. 

Customers Impacted: All Open Plan customers who use an SQL log. 

Workaround Before Fix: None. 

Files Updated:   openplan.exe 

 openplan.engine.dll 

 

Login 
Defect 1150449 

Description: When you logged into Open Plan, you sometimes encountered a "server busy" 
message. 

Customers Impacted: Some Open Plan customers. 

Workaround Before Fix: None. 

Files Updated:  OpenPlan.exe 

 OpenPlan.Engine.dll 

 OpenPlan.Language.0409.dll 
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Project » Schedule Driver Analysis 
Defect 1162878 
Description: If there were activities in a project that had predecessors that had been completed, the 
Schedule Driver Analysis process may have calculated incorrect paths because these relationships 
were no longer ignored. 
Customers Impacted: All Open Plan customers using Schedule Driver Analysis. 

Workaround Before Fix: None. 

Files Updated:  openplan.process.dll 

Security-Related Software Issues Resolved 
Additional security fixes are included in this release. 

Database Changes  
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed and online documentation.  

  

Deltek Open Plan 8.2 Installation Guide Added Oracle 18.3 to Supported Software  

Deltek Open Plan 8.2 Technical Overview and 
System Requirements Guide 

Added Oracle 18.3 to Supported Software 
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Open Plan 8.2 Cumulative Update 10 
Released: July 19, 2019 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 
Activities 

Defect 1148148 
Description: When you changed the relationship type of an existing interproject relationship in the 
Activity Details dialog in shared mode, an error occurred, and the relationship was deleted. 
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Edit the relationship in Exclusive mode. 

Files Updated:  openplan.engine.dll 

 openplan.exe 

 

Edit » Activity Details 
Defect 1149465 
Description: When users edited different activities in shared mode, changes were not saved and the 
following error displayed : "(14592) This record was changed by another user." 
Customers Impacted: All Open Plan customers using Shared Mode. 

Workaround Before Fix: No workaround for Shared Mode. 

Files Updated: openplan.engine.dll 

Security-Related Software Issues Resolved 
Additional security fixes are included in this release. 

Database Changes  
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed and online documentation. There are no 
documentation changes in this release. 
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Open Plan 8.2 Cumulative Update 09 
Released: July 12, 2019 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 
Project » Time Analysis 

Defect 1130182 
Description: When a subproject had a single child activity with a valid actual finish date, the early 
finish date on the subproject was incorrect when the Actual Date Option (Time Analysis dialog box 
Options tab) was enabled during time analysis. 
Customers Impacted: All Open Plan customers using subprojects and time analysis. 

Workaround Before Fix: None. 

Files Updated: openplan.process.dll 

Database Changes  
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed and online documentation. There are no 
documentation changes in this release. 
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Open Plan 8.2 Cumulative Update 08 
Released: May 20, 2019 

Enhancements 

Preserve Log History 
Open Plan now includes two new configuration options: 

 _PreserveLogFiles — When this option is enabled, all log files (except the datadictionary.log file) 
will have the following file name format: 

<Timestamp>_<OP User Name>_<Log File Simple Root Name>.log 

The timestamp takes the form of YYYYMMDDHHMMSS and uses Greenwich Mean time. For 
example, 20190417140045 represents 17 Apr 2019 14:00:45 (GMT). 

The log file simple root name is the name of the log file, for example, opwin.log. 

Example of a log file name: 20190417140045_JoeSmith_opwin.log. 

All log entries related to a particular process performed during a single Open Plan session are 
included in the same file. For example, if you run Time Analysis five times and Resource 
Scheduling three times in a single Open Plan session, the log output from all five Time Analysis 
runs is contained in a single analysis log file and the log output from all three Resource 
Scheduling runs is contained in a single log file.  

There are two settings: 

 0 = The option is not enabled. 

 1 = Open Plan uses the file name format described above. 

The default setting is 0. 

 _LogOutputCumulative — When this option is enabled, Open Plan appends all runs for a 
particular process or operation from all Open Plan sessions to the same log file.  

For example, when User 1 logs in and runs Time Analysis, Open Plan appends the results to the 
opp_ta.log file. When User 1 logs out and User 2 logs in and runs Time Analysis, Open Plan 
appends the results to the same opp_ta.log file if both users share the same working folder. If 
both User 1 and User 2 are logged in at the same time and share the same working folder, when 
they run Time Analysis, Open Plan appends their respective results to separate log files and 
renames one of the log files to, for example, opp_ta_User1.log. 

This option is ignored if _PreserveLogFiles is enabled. 

There are two settings: 

 0 = The option is disabled. 

 1 = The option is enabled. 

The default setting is 0. 

 

Note: You can set these in the System Preferences Defaults dialog box (On the File menu, click 
Preferences » Application. On the Options dialog box Advanced tab, click Defaults.) 
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Time Analysis Log Enhancements 
Previously, the Time Analysis log file, Opp_TA.log, only recorded the following information: 

 Indications for some time analysis options that had been set 

 A list of all start activities in the project 

 A list of all end activities in the project 

 All system or error messages generated during time analysis 

The log file has now been enhanced to log all options on the Time Analysis dialog box. 

  

Baseline Processing Log Enhancements 
Previously, baseline processing did not record all options to the OPWIN.log file. The log file has now been 
enhanced to log all options on the Update Baseline and Add Baseline dialog boxes. 
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PM Compass Integration Enhancements 
Additional improvements in the integration between PM Compass and Open Plan are included in this 
release. 

Software Issues Resolved 
Views » Spreadsheet View 

Defect 1105465 
Description: When you opened a subsectioned view, filtered on a calculated field, and expanded the 
subsection, Open Plan sometimes went into a loop.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None. 

Files Updated: openplan.engine.dll  

Database Changes  
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed and online documentation.  

Document Title Description of Change 

Open Plan Online Help Topic: Standard Open Plan Options — Added _PreserveLogFiles and 
_LogOutputCumulative descriptions.  

Topic: Time Analysis Session Log — Edited to say that the Time Analysis 
log now includes all options on the Time Analysis dialog box. 

Topic: Baseline Processing Log —  Add this as a new topic. The baseline 
opwin.log includes all options on the Update Baseline and Add Baseline 
dialog boxes. 

Topic: Add Baseline Dialog Box — Added a note about the opwin.log 
session log. 

Topic: Update Baseline Dialog Box — Added a note about the opwin.log 
session log. 

 

Note: For more information about the above fields and notes, see the 
Cumulative Update 08 Enhancements section in this document. 



Open Plan 8.2 Cumulative Update 07 

Release Notes 10 

 

Open Plan 8.2 Cumulative Update 07 
Released: April 5, 2019 

Enhancements 

Schedule Driver Analysis Shared Mode 
Users can now run Schedule Driver Analysis in shared mode. When run in shared mode, the results of 
the path analysis are not stored. They are available while the project is open.  

 

 

Restore the Views.bk3 File 

To restore the views.bk3 file: 

1. In Open Plan, click  » Manage Files » Restore Data. 

2. Navigate to the Open Plan Sample Data folder under the installed Open Plan directory.  

The default is: C:\Program Files (x86)\Deltek\Open Plan Professional 8.2\Sample Data. 

3. Select Views.bk3 and click Open. 

4. On the first page of the Restore Wizard, select View: SDA_Pathbar and click Next. 

 
5. On the Restore – Details page, select the following: 

 System Library » Bar Sets 

 PATHBAR_BRS 

 System Library » Calculated Fields » Activity 

 _Path_Bar 

 SDA_Value 

 System Library » Filters » Activity 

 Path 1 

 Path 2 

 Path 3 

 Path 9 

 Path 10 

 Path 11 

 Path 17 

 Path 18 

 Path 19 

Note: You cannot currently use the schedule driver via OLE automation while in Shared Mode. 

Important: In order to run Schedule Driver Analysis in Shared Mode, you need to restore the 
views.bk3 file. This only needs to be done once for the Open Plan data source. There is no need for 
every user to complete these steps. 

See Restore the Views.bk3 File below for steps. 

Note: You do not need to restore any other views. 
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 Path 4 

 Path 5 

 Path 6 

 Path 7 

 Path 8 

 Path 12 

 Path 13 

 Path 14 

 Path 15 

 Path 16 

 Path 20 

 Path 1To5 

 Path 1To20 

 

6. Click Finish. 

 

Software Issues Resolved 
Project » Baselines  

Defect 1057448 
Description: Update Baseline deleted Baseline Start and Baseline Finish dates.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix:  

1. Select Edit » Dialogs » Baselines. 

2. Select the baseline you want to update and click Select. 

3. Re-open Baselines and update the baseline in question. 

Files Updated:  OpenPlan.Process.dll 

 OpenPlan.Language.409.res 

 
Edit » Activity Progress  

Defect 1029079 
Description: You could not modify the activity PPC for an activity with an EVT type of Resource % 
Complete in a spreadsheet or bar chart.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Edit the activity PPC in the Progress dialog box or modify assignment 
PPCs to adjust the activity PPC to the desired value. 

Files Updated: openplan.exe 

 
File » Change Mode  

Defect 1075899 
Description: Applying a temporary exclusive lock on a large master project with many external 
subprojects was slow (several hours).  
Customers Impacted: All Open Plan customers using project locks. 

Workaround Before Fix: Make the required changes in exclusive mode. 

Note: If you are prompted to overwrite the files, click Yes. This allows the view to work in 
Shared Mode. 
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Files Updated: OpenPlan.exe 

 OpenPlan.ext.dll 

 OpenPlan.engine.dll 

 
Views » Spreadsheet View  

Defect 1025351 
Description: When a user character field was linked to a lookup table, it caused characters that you 
entered in a spreadsheet or bar chart view to display in uppercase. This did not occur when you used 
the Activity Details dialog box to enter text.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Enter text using the Activity Details » User Fields instead of the view. 

Files Updated: openplan.exe 

 
Project » Resource Scheduling  

Defect 1092094 
Description: During resource scheduling, a crash sometimes occurred when a subproject activity 
was being scheduled.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None. 

Files Updated:  OpenPlan.Process.dll 

Database Changes  
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed and online documentation. There are no 
documentation changes in this release. 
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Open Plan 8.2 Cumulative Update 06 
Released: March 6, 2019 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 
Project » Time Analysis 

Defect 1059342 
Description: When you ran Time Analysis, the expected finish date was not honored.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None. 

Files Updated:   OpenPlan.Process.dll  

 

Defect 1059919 
Description: When you enabled the Observe Actual Future Dates option, in certain scenarios 
where the actual start date was > time now and no actual finish date was specified, time analysis 
calculated invalid finish dates.  
Customers Impacted: All Open Plan customers using the Observe Actual Future Dates option. 

Workaround Before Fix: None. 

Files Updated:   OpenPlan.Process.dll 

 
Defect 1067372 
Description: If you selected the Observe Actual Future Dates option on the Time Analysis dialog 
box: 

 An actual start date that was greater than Time Now affected the early start date of 
subprojects in the parent chain, even if there were planned activities with earlier early start 
dates, and 

 An actual finish date that was greater than Time Now affected the early finish date of 
subprojects in the parent chain even if there were planned or incomplete activities under the 
subproject.  

Customers Impacted: All Open Plan customers using the Observe Actual Future Dates option. 

Workaround Before Fix: None. 

Files Updated: openplan.process.dll 

 

Defect 1073868 
Description: When the Observe Actual Future Dates option was selected, the target dates were 
not honored.  
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Customers Impacted: All Open Plan customers using the Observe Actual Future Dates option. 

Workaround Before Fix: Deselect the Observe Actual Future Dates option if it is not necessary for 
a given project. 

Files Updated: openplan.process.dll 

 

Project » Activity Steps 
Defect 1070313 
Description: When you copied and pasted an activity, the steps were not included.  
Customers Impacted: All Open Plan customers using activity steps. 

Workaround Before Fix: Copy/paste steps from one activity to another in the Activity Details dialog 
box. 

Files Updated: openplan.engine.dll 

Database Changes  
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed and online documentation.  

Documentation Title Description of Change 

Open Plan Online Help A new topic titled, “Time Analysis Rules and Conditions” has been 
added to the online help. 

The help topic can be found in the following location: Working with 
Projects » Project Analysis » Time Analysis » Time Analysis Rules and 
Conditions. 
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Open Plan 8.2 Cumulative Update 05 
Released: December 19, 2018 

Enhancements 

Users with Read-Only Access Can Now Approve Change Requests 
A user who logs into Open Plan, with read-only access to an Open Plan project and it’s ancillary files, can 
now approve a PM Compass change request in the Open Plan Add-In.  

 

Time Analysis: Observe Actual Future Dates  
The Time Analysis Options tab now has a new option titled Observe Actual Future Dates. When you 
select this option, Time Analysis respects Actual Start and Finish dates that occur AFTER Time Now as 
long as the dates are valid and the actual start date is less than or equal to the actual finish date. The 
default behavior in Time Analysis is to reject actual dates that occur after Time Now as invalid.  

For example, Time Now is 11/1. Task A is a 10-day task with a planned start on Time Now (11/1) and a 
planned finish of 11/14. On Monday 11/5 (the system date), you report that you have finished Task A and 
you set the Actual Finish to 11/5.  

 If the Observe Actual Future Dates option is not selected, the system sees this as invalid 
because it is after Time Now; therefore, the activity is still planned to finish on 11/14 and 
successor activities can start on 11/15.  

 If the Observe Actual Future Dates option is selected, the system sees the activity as 
completed on 11/5 and successor activities can start on 11/6. 

Note: In order for the above fix to take effect, you must download and install: 

 PM Compass 8.1 Cumulative Update 14 (when released) 

 Deltek Open Plan 8.2 Integration for PM Compass 8.1 (when released) 

 Open Plan 8.2 Add-In for PM Compass 8.1 (when released) 

The Integration and Add-In files will be released at the same time as PM Compass 8.1 Cumulative 
Update 14. 
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Relationships To/From Closed External Subprojects 
The Time Analysis Advanced tab now has a new option titled Relationships To/From Closed External 
Subprojects. 

Select Observe (the default) if you want Open Plan to take into account all relationships to or from closed 
external subprojects. Select Ignore if you want Open Plan to ignore relationships to or from closed 
external subprojects.  

For example, you have the following activities: 

• Activity A (duration = 10 days) in open Subproject 1 

• Activity B (duration = 5 days) in closed Subproject 2 

Activity A is a predecessor to Activity B. If you select Ignore, both Activity A and Activity B can start at the 
same time. If you select Observe, Activity A must finish before Activity B can begin. 

 

If selected, Open Plan 
respects Actual Start and 

Finish dates that occur AFTER 
Time Now as long as the dates 
are valid and the actual start 
date is less than or equal to 

the actual finish date 

Determine whether you 
want Open Plan to ignore or 

take into account all 
relationships to/from closed 

external subprojects 
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Software Issues Resolved 
Project » Baselines 

Defect 1008887 
Description: Baseline dates did not update when a new baseline was created unless you first 
cleared the dates.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Before creating a new baseline, select < No Baseline > and check the 
Clear baseline data when No Baseline is selected option. 

Files Updated:   OpenPlanEngine.dll 

 

Log Files 
Defect 1038500 
Description: When PM Compass ran Open Plan scheduling processes such as Time Analysis, log 
files for the scheduling process were not created.  
Customers Impacted: Customers running PM Compass. 

Workaround Before Fix: None. 

Additional Notes: This applies to the Open Plan Time Analysis, Resource Scheduling, Risk Analysis, 
Cost Calculations, and Progress Calculations. These log files are typically only required by Customer 
Care when investigating issues related to PM Compass/Open Plan integration. 

Files Updated:    OpenPlan.Engine.dll 

 OpenPlan.Ext.dll 

 OpenPlan.Process.dll 

 
 

Batch Interface 
Defect 1043444 
Description: Open Plan crashed in certain scenarios where it was being invoked from the command 
line (for example, when it was launched via Windows 2012 Task Scheduler using an internal batch 
file). 
Customers Impacted: All Open Plan customers launching Open Plan via a command line. 

Workaround Before Fix: None. 

Files Updated:   OpenPlan.Language.409.dll 

 OpenPlan.exe 

Note: In order for the above fix to take effect, you must download and install: 

 PM Compass 8.1 Cumulative Update 14 (when released) 

 Deltek Open Plan 8.2 Integration for PM Compass 8.1 (when released) 

The Integration file will be released at the same time as PM Compass 8.1 Cumulative Update 14. 
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 PPM.SysInfo.dll 

Database Changes  
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed documentation.  

Documentation Title Description of Change 

Open Plan Online Help A new option titled Observe Actual Future Dates has been added to 
the Time Analysis Dialog Box Options Tab. 

A new option titled Relationships To/From Closed External 
Subprojects has been added to the Time Analysis Dialog Box 
Advanced Tab topic. 

The help topics can be found in the following location of the online help: 
Working with Projects » Project Analysis » Time Analysis » Tabs and 
Dialog Boxes » Time Analysis Dialog Box. 
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Open Plan 8.2 Cumulative Update 04 
Released: November 9, 2018 

Enhancements 
There are no enhancements in this release. 

Software Issues Resolved 
EPM Security Administrator 

Defect 992911 
Description: The values you assigned in the Manager and Alternate Manager fields on General tab 
of the User Details form in the EPM Security Administrator tool were not saved.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None.  

Files Updated:  EPMSecAdmin.exe 

 
Views 

Defect 1015384 
Description: When you made changes in a view and exited Open Plan, the system no longer 
displayed a message asking if you want to save changes.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Save project manually before exiting or close the view and then exit Open 
Plan.  With the latter, you will be prompted to save.  

Files Updated:  openplan.exe 

 
Defect 1017321 
Description: If you used the Organize Spreadsheet Columns dialog box to remove the column that 
was selected in the view, an "Encountered an improper argument" error displayed and you had to use 
Windows Task Manager to close Open Plan.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None.  

Files Updated:  openplan.exe 

 
Views » Spreadsheet View 

Defect 1014767 
Description: Calculated fields were not displaying the summary value in the Spreadsheet and Bar 
view subsection headers.  
Customers Impacted: All Open Plan customers. 
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Workaround Before Fix: Add or move a date column before the Calculated Field column in the 
spreadsheet.  

Files Updated:  openplan.exe 

 
File » Import – Export » Primavera 

Defect 1007841 
Description: When you imported a P6 XER baseline project, the calendars were not imported into 
Open Plan if they were not also used on activities in the non-baseline project.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None.  

Files Updated:  PPM.Integration.Primavera.dll 

 
Edit » Activity Details 

Defect 1018033 
Description: You could not make selections in the relationship grids on the Activity Details dialog box 
when the project was open in read-only mode. This made it impossible to select an activity to use with 
the GoTo button.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None.  

Files Updated:  OpenPlan.exe 

Database Changes 
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed documentation. There are no 
documentation changes in this release. 
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Open Plan 8.2 Cumulative Update 03 
Released: September 28, 2018 

Enhancements 

Milestones Professional Add-On Module 
Milestones Professional is now included as an Add-on with the Open Plan installation. The tool allows you 
to use the powerful, flexible graphics of Milestones Professional with the strength of the Open Plan 
scheduling engine.    

 

Log File System Information 
When Open Plan starts, the system now automatically sends the following information to the OPWin.log 
file: 

 Database name and version 

 Database driver and version 

 CPU information 

 Physical memory (total and free) 

 Virtual memory (total and free) 

 Operating system and version 

 Disk space on drive C: 

 Disk space on drive where the application is installed, if other than C: 

 System locale 

 Input locale 

 Running under Citrix? 

 Running under VMWare? 

 Running under Remote Desktop? 

If an error occurs, you can send the log file to Customer Care who can determine the environment you 
are using and use this information to help diagnose the issue and provide a resolution. 

Software Issues Resolved 
File » Import – Export » Primavera 

Defect 960232 
Description: When you imported a P6 Web baseline project, the calendars were not imported into 
Open Plan if they were not also used on activities in the non-baseline project.  
Customers Impacted: All Open Plan customers using P6 baseline project imports. 

Note: You must have a copy of Milestones Professional on your computer for the interface to work. 
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Workaround Before Fix: None.  

Files Updated:  PPM.Integration.Primavera.dll 

 
Defect 968132 
Description: When you performed a P6 XER import, the calendars that were not referenced by one 
of the selected projects were not imported. This could result in calendars that were only referenced by 
resources not being loaded. 
Customers Impacted: All Open Plan customers importing P6 XER projects. 

Workaround Before Fix: None.  

Files Updated:  PPM.Integration.Primavera.dll 

 
Project 

Defect 968148 
Description: When you updated a chart, the Milestones Pro Interface tool was not highlighting 
symbols that were updated.  
Customers Impacted: All Open Plan customers using the Milestones Pro Interface tool. 

Workaround Before Fix: None.  

Files Updated: MilestonesInterface.exe 

 
Project » Undo 

Defect 968135 
Description: On the Code Details dialog box, when you clicked Undo, the code values did 
not update immediately.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: Click the navigation to update the code values.  

Files Updated:  OpenPlan.exe 

 
Project » Views 

Defect 968136 
Description: The P6WBSVW view no longer displayed activities directly under the P6 project WBS.  
Customers Impacted: All Open Plan customers using Primavera P6. 

Workaround Before Fix: Use another view to look at activities.  

Files Updated:  OpenPlan.Engine.dll 

 OpenPlan.exe 

 OpenPlan.Ext.dll 

 OpenPlan.Language.409.dll 

 OpenPlan.Primavera.dll 
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Defect 969780 
Description: Using <CTRL + C> to copy a column in a view (for example, BARVW) was not 
working.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: On the Edit menu, click the Copy button.  

Files Updated: OpenPlan.exe 

 
Project » Time Analysis 

Defect 970531 
Description: When there was an ASDATE on an activity, Time Analysis set Total Float to 0.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None.  

Files Updated: OpenPlan.Process.dll 

 
Project » Baselines 

Defect 974963 
Description: When you updated the baseline without selecting Ignore Progress, Use Original 
Project Start Date, the baseline dates might not begin on the correct date.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: This was due to resource actual unit/cost records with dates prior to the 
activity. Correct those dates to get the expected results.  

Files Updated: OpenPlan.Process.dll 

 
EPM Security Administrator Help 

Defect 968151 
Description: The “Define Group Profiles Overview” of the EPM SA Help for Open Plan 8.2 was not 
updated.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None.  

Additional Note: A note in the topic mentioned that "A user must belong to at least one group to log 
on to a supported application." It was updated to say that, in Open Plan 8.0 and higher versions, a 
user can login to Open Plan even without belonging to a Group in EPM SA. 

Files Updated: Security.chm 

Database Changes 
This section includes the changes made to the database for this release. There are no database changes 
in this release. 
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Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed documentation.  

Document Details 

Deltek Open Plan Milestones Interface Add-In This Milestones Professional interface document 
is located in the same folder as the Milestones 
Professional Interface Add-In module. 
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Open Plan 8.2 Cumulative Update 02 
Released: September 4, 2018 

Enhancements 
There are no enhancements included in this release. 

Software Issues Resolved 
Open Plan Defect Related to PM Compass Integration 

Defect 992149 
Description: After approval in Open Plan, in some circumstances, the changed baseline did not 
update the baseline dates, which made the baseline incorrect.  
Customers Impacted: All Open Plan customers integrating with PM Compass. 

Workaround Before Fix: None.  

Files Updated: OpenPlan.Engine.dll 

Database Changes 
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed documentation. There are no 
documentation changes in this release. 
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Open Plan 8.2 Cumulative Update 01 
Released: July 20, 2018 

Enhancements 
There are no enhancements included in this release. 

Software Issues Resolved 
File  » Import – Export MSP 

Defect 968126 
Description: The Microsoft Project work week shifts were not exported correctly when you exported 
shift times in the 24-hour time format.  
Customers Impacted: All Open Plan customers exporting to Microsoft Project. 

Workaround Before Fix: None.  

 

Log File 
Defect 968128 
Description: When an error message that contained a % character was output to the log file, it 
sometimes caused Open Plan to crash.  
Customers Impacted: All Open Plan customers. 

Workaround Before Fix: None.  

 

Schedule Driver Analysis 
Defect 968131 
Description: Schedule Driver Analysis was not accounting for multiple different calendars in it's 
analysis along a path and sometimes came up with an incorrect path order in the results.  
Customers Impacted: All Open Plan customers using Schedule Driver Analysis. 

Workaround Before Fix: None.  

 

Update Baseline 
Defect 968614 
Description: The Update Baseline option to Ignore Progress and use the original project start date 
was not working.  
Customers Impacted: All Open Plan customers using Update Baseline with Ignore Progress. 

Workaround Before Fix: None.  
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Activity Details 
Defect 968746 
Description: The Activity Details dialog box Steps tab did not store the activity PPC when you 
completed a step if you did not select Allow % Complete on Steps on the Project Properties dialog 
box Preferences tab.  
Customers Impacted: All Open Plan customers using steps. 

Workaround Before Fix: Select Allow % Complete on Steps, toggle the step Complete status and 
click Apply.  

 
Defect 968751 
Description: The Activity Details dialog box Steps tab didn't always round PPC to 100% when all 
steps were complete.  
Customers Impacted: All Open Plan customers using steps Earned Value Technique. 

Workaround Before Fix: Adjust step weights.  

 

Earned Value 
Defect 968755 
Description: The Activity Spreadsheet did not disable the Physical % Complete column when EVT 
was set to something other than Percent Complete. This meant that users could enter PPC values 
that were inconsistent with their selected EVT.  
Customers Impacted: All Open Plan customers using Earned Value. 

Workaround Before Fix: Run progress calculations to update PPC based on EVT.  

 
Defect 968726 
Description: A manually entered PPC was not updated/corrected by progress calculations when the 
EVT was Steps.  
Customers Impacted: All Open Plan customers using Earned Value. 

Workaround Before Fix: None.  

 

Resource Scheduling 
Defect 968147 
Description: Resource scheduling reported an incorrect Schedule Finish Date (SFDATE) for Finish 
Milestones with some data.  
Customers Impacted: All Open Plan customers using milestones. 

Workaround Before Fix: None.  
 



Open Plan 8.2 Cumulative Update 01 

Release Notes 28 

 

Database Changes 
This section includes the changes made to the database for this release. There are no database changes 
in this release. 

Data Changes 
This section includes changes to data applied by scripts. There are no data changes in this release. 

Documentation Changes 
This section includes details of sections changed in the printed documentation. There are no 
documentation changes in this release. 
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Appendix A: Download and Install the 
Cumulative Update 

Download and Install the Cumulative Update 
1. From Internet Explorer, go to https://dsm.deltek.com.  

2. Click Run Deltek Software Manager.  

3. Log in using your Deltek Customer Care Connect credentials.  

4. In the left pane of the Deltek Software Manager, expand your Deltek product.  

5. Expand the Cumulative Updates folder for your product and select the update to download.  

6. Click Download at the bottom of the screen. 

7. Download the file to a local workstation or a centralized server location. 

8. Double-click the file to start the cumulative update. 

Verify the Cumulative Update Installation 
You can verify the cumulative update in one of two ways: 

 In Open Plan, click the product icon  in the top left corner, click Help » About Open Plan and 
confirm that the version number reflects the update. 

 Check the file dates in your Open Plan folder to see if they match the file dates in the update zip file. 

 

https://dsm.deltek.com/
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Appendix B: If You Need Assistance 
If you need assistance installing, implementing, or using Open Plan, Deltek makes a wealth of information 
and expertise readily available to you. 

Customer Services 
For over 30 years, Deltek has maintained close relationships with client firms, helping with their problems, 
listening to their needs, and getting to know their individual business environments. A full range of 
customer services has grown out of this close contact, including the following: 

 Extensive self-support options through the Deltek Support Center. 

 Phone and email support from Customer Care analysts 

 Technical services 

 Consulting services 

 Custom programming 

 Classroom, on-site, and Web-based training 

 

Deltek Support Center 
The Deltek Support Center is a support Web site for Deltek customers who purchase an Ongoing Support 
Plan (OSP).  

The following are some of the many options that the Deltek Support Center provides: 

 Search for product documentation, such as release notes, install guides, technical information, 
online help topics, and white papers 

 Ask questions, exchange ideas, and share knowledge with other Deltek customers through the 
Deltek Support Center Community 

 Access Cloud-specific documents and forums 

 Download the latest versions of your Deltek products 

 Search Deltek’s knowledge base 

 Submit a support case and check on its progress 

 Transfer requested files to a Customer Care analyst 

 Subscribe to Deltek communications about your products and services 

 Receive alerts of new Deltek releases and hot fixes 

 Initiate a Chat to submit a question to a Customer Care analyst online 

 

Attention: Find out more about these and other services from the Deltek Support Center. 

Attention: For more information regarding Deltek Support Center, refer to the online help available 
from the Web site. 
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Access Deltek Support Center 
To access the Deltek Support Center:  

1. Go to https://deltek.custhelp.com. 

2. Enter your Deltek Support Center Username and Password. 

3. Click Login. 

 
 

 

 

Note: If you forget your username or password, you can click the Need Help? button on the login 
screen for help. 

https://deltek.custhelp.com/


 

 

 

Deltek is the leading global provider of enterprise software and solutions for government contractors, 
professional services firms and other project-based businesses. For decades, we have delivered 
actionable insight that empowers our customers to unlock their business potential. 22,000 organizations 
and millions of users in over 80 countries around the world rely on Deltek to research and identify 
opportunities, win new business, recruit and develop talent, optimize resources, streamline operations 
and deliver more profitable projects. Deltek – Know more. Do more.® www.deltek.com 

http://www.deltek.com/

	Overview
	Custom Programs Affected

	Open Plan 8.2 Cumulative Update 11
	Enhancements
	Support for Oracle 18.3

	Software Issues Resolved
	Project » Cost Calculations
	File » Change Mode
	Edit » Activity Details
	Edit » Activity Progress
	Login
	Project » Schedule Driver Analysis
	Security-Related Software Issues Resolved

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 10
	Enhancements
	Software Issues Resolved
	Activities
	Edit » Activity Details
	Security-Related Software Issues Resolved

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 09
	Enhancements
	Software Issues Resolved
	Project » Time Analysis

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 08
	Enhancements
	Preserve Log History
	Time Analysis Log Enhancements
	Baseline Processing Log Enhancements
	PM Compass Integration Enhancements

	Software Issues Resolved
	Views » Spreadsheet View

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 07
	Enhancements
	Schedule Driver Analysis Shared Mode
	Restore the Views.bk3 File

	Software Issues Resolved
	Project » Baselines
	Edit » Activity Progress
	File » Change Mode
	Views » Spreadsheet View
	Project » Resource Scheduling

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 06
	Enhancements
	Software Issues Resolved
	Project » Time Analysis
	Project » Activity Steps

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 05
	Enhancements
	Users with Read-Only Access Can Now Approve Change Requests
	Time Analysis: Observe Actual Future Dates
	Relationships To/From Closed External Subprojects

	Software Issues Resolved
	Project » Baselines
	Log Files
	Batch Interface

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 04
	Enhancements
	Software Issues Resolved
	EPM Security Administrator
	Views
	Views » Spreadsheet View
	File » Import – Export » Primavera
	Edit » Activity Details

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 03
	Enhancements
	Milestones Professional Add-On Module
	Log File System Information

	Software Issues Resolved
	File » Import – Export » Primavera
	Project
	Project » Undo
	Project » Views
	Project » Time Analysis
	Project » Baselines
	EPM Security Administrator Help

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 02
	Enhancements
	Software Issues Resolved
	Open Plan Defect Related to PM Compass Integration

	Database Changes
	Data Changes
	Documentation Changes

	Open Plan 8.2 Cumulative Update 01
	Enhancements
	Software Issues Resolved
	File  » Import – Export MSP
	Log File
	Schedule Driver Analysis
	Update Baseline
	Activity Details
	Earned Value
	Resource Scheduling

	Database Changes
	Data Changes
	Documentation Changes

	Appendix A: Download and Install the Cumulative Update
	Download and Install the Cumulative Update
	Verify the Cumulative Update Installation

	Appendix B: If You Need Assistance
	Customer Services
	Deltek Support Center
	Access Deltek Support Center


